This project has moved. For the latest updates, please go here.

Enable Multiple Threading

Apr 6, 2011 at 6:58 PM

Hi,

We have a fairly large row in a fact table which is not responding to small changes through the Multiple Hash component.  We have been testing many scenarios, even changing from MD5 to SHA512, with no luck. We just testing by changing the "Enable Multiple Threading" from None to "On" and received the Updates as expected. 

Can you provide some additional information on this drop down - "Enable Multiple Threading" and how it should be used.

Thanks in advance,
Shari

Coordinator
Apr 7, 2011 at 7:39 PM

There was an issue with the earlier versions of Multiple Hash, (prior to V1.3) where the hash wouldn't detect a change when two adjacent columns were changing from Null to Valued (where the Value was the same for both columns).

It also looks like I forgot to push V1.3.1 which matches Change Set 60073, which corrects an issue when Auto or On is enabled for Mutliple Hash's AND Safe Null Handling is enabled.

Unfortunately I won't be able to post an updated version until the first week of May 2011, as I am on Holidays.

 

From your description I suspect you don't have Safe Null Handling enabled (see the Input Columns tab).

  • If you will have a large number of output columns, and will be executing on a multi core machine, then consider enabling the Multiple Threading
    1. None will not do Multiple Threading
    2. Auto will do some basic checking, before enabling multiple threading (number of CPU's, and Number of Outputs)
    3. On will enable multiple threading (regardless of the number of CPU Core's etc.
  • Coordinator
    May 20, 2011 at 12:27 PM

    I have now released V1.3.1.

    Marked as answer by kmartin on 7/8/2014 at 6:34 AM